Home networking question

Started by sbr, March 08, 2012, 08:54:20 PM

Previous topic - Next topic

sbr

I am trying to get my laptop, which is on wireless to print to the one printer I have in my house.

I have 2 desktop PCs, one is mine the other is the kids'.  Both desktops run XP; the printer is connected to my PC via USB.  For a number of years the kids' PC was connected through wireless and it was able to print to the one printer.  Eventually I got off my ass and  ran a cable over to it so it is now wired and still connects to the printer.

My laptop runs Windows 7, which I am very, very new to, and is obviously on wireless. 

Last night I worked the Google machine a bit and found this, but then the kids pissed me off so I lost interest until this afternoon.

I have changed the laptop Workgroup to the same as the 2 desktops.  I have verified the network discovery and file/printer sharing according to the webpage I linked above. 

Now the funny business:


  • According to the Network page on the Laptop it could see my router but nothing else.
  • My PC could see the router and nothing else.
  • The kids' PC could see the laptop but nothing else.

At this point I played around with the Set Up Home or Small Office wizard on the 2 XP machines.

Now along with the above the 2 XP machines can see each other; my PC does not see the laptop and the laptop doesn't see either desktop so obviously doesn't see the printer either.

Anyone have any ideas how to get these stupid things to get along?

viper37

Is the printer shared on the computer it is connected to? Can't remember how it's done exactly on XP, but you need to go into your printer properties, IIRC.

Then, you need to download Windows 7 drivers for your printer, to install it on Windows 7.  During the install process, it should discover the printer.

If you have a firewall in XP, it might be interfering with your network connections.
I don't do meditation.
I drink alcohol to relax, like normal people.

MadImmortalMan

Turn on sharing in the Win7 pc by going: Network and Sharing Center-->Advanced Sharing Settings

In the profile you're using, turn on network discovery and file and printer sharing. Turn off password protection.
"Stability is destabilizing." --Hyman Minsky

"Complacency can be a self-denying prophecy."
"We have nothing to fear but lack of fear itself." --Larry Summers

CountDeMoney

I renamed my SSID "FestungPuddyTat".

Caliga

0 Ed Anger Disapproval Points